Back

Elevated AWS STS errors

September 3, 2026 at 10:27 PM UTC Resolved after 1h 12m

Updates

Resolved

Services have recovered, and we are continuing to monitor system stability.

September 3, 2026 at 11:40 PM UTC
Monitoring

The intermittent issue affecting AWS credential refreshes appears to be resolved. Error rates in our backend systems have subsided, and we’ll continue to monitor closely.

September 3, 2026 at 10:47 PM UTC
Investigating

We’re investigating intermittent elevated error rates with AWS STS in us-west-2, including throttling and temporary service-unavailable responses that may affect SAML sign-in. Users may need to retry login, and some backend processing may be delayed while we monitor the situation.

September 3, 2026 at 10:27 PM UTC