Search and Chat failures
March 9, 2026 at 02:42 PM UTC
Resolved after 1h 52m
Updates
Resolved
Google has confirmed multiple GCP products are affected in us-central1. Multiple cloud services impacted
Issue has been mitigated now after a confirmation from google
March 9, 2026 at 04:34 PM UTC
Monitoring
Google has confirmed multiple GCP products are affected in us-central1. Multiple cloud services impacted
March 9, 2026 at 02:42 PM UTC