Users facing login issues
March 4, 2026 at 02:51 AM UTC
Resolved after 6h 15m
Updates
Resolved
Fix has been rolled out successfully and users are no longer facing login issues
March 4, 2026 at 09:07 AM UTC
Identified
We have the fix ready, we are actively working on rolling out the fix
March 4, 2026 at 04:43 AM UTC
Identified
Actively working on mitigation.
March 4, 2026 at 02:51 AM UTC