Back

Permanent Fix Deployed

April 22, 2026 at 04:30 PM UTC Resolved after 14h 13m

Updates

Resolved

We have rolled out a permanent fix to this issue

April 23, 2026 at 06:43 AM UTC
Monitoring

We have deployed a fix for the issue, and early signals show performance has stabilized.

We are keeping the systems under heightened monitoring to ensure they remain stable.

Impact: Most users should now see [normal behavior / significantly improved performance]. If you continue to experience issues, please contact Glean support.

April 22, 2026 at 05:02 PM UTC
Identified

We are rolling out a mitigation for the issue affecting chat and agents for customers using Glean key for LLMs.
We will continue to closely monitor system behavior as the mitigation completes.

April 22, 2026 at 04:35 PM UTC
Investigating

Customers may experience chat failures.
Our engineering team is actively working to identify the root cause.
We’re sorry for the disruption and appreciate your patience while we investigate.

April 22, 2026 at 04:30 PM UTC