Back

Client Token management API is failing

July 3, 2026 at 09:26 AM UTC Resolved after 5h 35m

Updates

Resolved

The incident has been resolved.
We apologize for the disruption and appreciate your patience while we addressed this issue.

July 3, 2026 at 03:02 PM UTC
Monitoring

We have deployed a fix for the issue globally. We are keeping the systems under heightened monitoring to ensure they remain stable.

Impact: Most admin users should now see the Client Token management functionality restored. If you continue to experience issues, please contact Glean support.

July 3, 2026 at 02:21 PM UTC
Monitoring

We have deployed a fix for the issue globally. We are keeping the systems under heightened monitoring to ensure they remain stable.

Impact: Most admin users should now see the Client Token management functionality restored. If you continue to experience issues, please contact Glean support.

July 3, 2026 at 02:20 PM UTC
Identified

Incident:
Client Token management API is failing

We have identified the cause of the issue.
We are currently implementing a fix and monitoring its effect.

July 3, 2026 at 09:33 AM UTC
Identified

Incident:
Client Token management API is failing

We have identified the cause of the issue.
We are currently implementing a fix and monitoring its effect.

July 3, 2026 at 09:31 AM UTC
Identified

We have identified the cause of the issue.
We are currently implementing a fix and monitoring its effect.

July 3, 2026 at 09:26 AM UTC