Back

gemini-models-429-errors

February 27, 2026 at 02:19 PM UTC Resolved after 17h 42m

Updates

Resolved

Google confirms the issue is fixed.

February 28, 2026 at 08:02 AM UTC
Monitoring

GCP confirmed that the issue is resolved. Please refer -
https://status.cloud.google.com/incidents/41E5S3mkTGDfkZuJZH5k

February 27, 2026 at 04:20 PM UTC
Identified

We opened a case with Google. They said an internal error is causing 429 errors, and the product team is fixing it.

February 27, 2026 at 03:09 PM UTC
Investigating

Gemini models running into 429s across the customers regardless of Glean Key or Customer Key.

February 27, 2026 at 02:19 PM UTC