Customers using Glean LLM key are facing partial outage beginning 2025 May 23 6:00 UTC. Error rate: 0.5% of Users

Incident Report for Glean

Resolved

All regions have recovered
Posted May 23, 2025 - 23:10 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted May 23, 2025 - 21:03 UTC

Update

We have started to see recovery, most US regions have recovered. Still waiting on updates from Azure for remaining regions.
Posted May 23, 2025 - 21:02 UTC

Update

Azure team has identified the issue. They are working on a fix.
Posted May 23, 2025 - 20:16 UTC

Update

We are continuing to work on a fix for this issue.
Posted May 23, 2025 - 16:34 UTC

Identified

We are actively working with Azure Support to fix the issue
Posted May 23, 2025 - 16:33 UTC
This incident affected: Assistant.