Back

Glean MCP outage

January 28, 2026 at 06:01 AM UTC Resolved after 5h 40m

Updates

Resolved

The issue has been resolved.

January 28, 2026 at 11:41 AM UTC
Monitoring

Rolling out fix to the customers.

January 28, 2026 at 08:42 AM UTC
Identified

Issue has been identified and fix is being rolled out.

January 28, 2026 at 07:31 AM UTC
Investigating

Glean mcp tool is unavailable.

January 28, 2026 at 06:01 AM UTC